


Liquid Rhythm User Manual 
April 2015 

The Liquid Rhythm User Manual is written by: 
Haig Beylerian 
Saro Migirdicyan 
Allison Janzen 
Adil Sardar 
Glen Kappel 
Jason Spanu 

Legal Notices 
This product is subject to the terms and conditions of a software license agreement. 

This user manual is copyrighted © 2015 by WaveDNA Ltd., (hereafter “WaveDNA”), with all rights 
reserved. Under copyright laws, this user manual may not be duplicated in whole or in part without 
the written consent of WaveDNA. 

Product features, specifications, system requirements and availability are subject to change without 
notice. 

Document Feedback 
We are constantly looking for ways to improve our documentation. If you have any comments, 
corrections or suggestions regarding our documentation, please email us at info@wavedna.com.  

mailto:info@wavedna.com


i

Chapter 1 Getting Started with Liquid Rhythm  1

System requirements & Installation 1

Mac  1

PC 1

OS X Installation  1

Windows Installation  2

Nomenclature   3

OS X & Windows Keyboard Commands Terminology  3

Mouse Terminology  3

Welcome Screen  4

Watch Quickstart Video  4

Read Quickstart Guide  4

Start Guided Walkthrough  4

Show On Startup  4

Close  4

Settings  5

Audio  5

Audio  5

Driver  5

Input Device  5

Output Device  5

Sample Rate  5

Look and Feel  6

Library  6

Devices  7

Device Names  7

Options  7

MIDI Hit  7

MIDI Mapping  7

How to connect a MIDI Device to your computer  8

Testing Your External MIDI Controller  8



ii

Chapter 2 Integrating Liquid Rhythm with your Digital Audio 
Workstation  9

OS X 10

Ableton Live 8  10

Stereo plug-in steps: 10

Ableton Live 9  10

Stereo plug-in steps: 10

Cubase 7 10

Stereo plug-in steps: 10

Logic Pro 9  11

Stereo plug-in steps: 11

Multi-output plug-in steps: 11

Logic Pro X 12

Stereo plug-in steps: 12

Multi-output plug-in steps: 12

Presonus Studio One 2  13

Stereo plug-in steps: 13

Multi-output plug-in steps: 13

Interplug-in MIDI Routing 14

Pro Tools 10  14

Stereo plug-in steps: 14

Tracktion 5 14

Stereo plug-in steps: 14

Windows  15

Ableton Live 9  15

Max for Live patch Exclusive Features  16

Clip Controls  16

Refresh from Live  17

Color-Coordinated Arranger  17

Clip Selector  17

Loop Library  18



iii

Chapter 3 Project File Controls  19

Project File Commands  19

New Project  19

Open...  19

Open Recent  19

Save  19

Save As...  19

Consolidated Save  19

Import MIDI File...  19

Export to MIDI File...  20

Quick MIDI Export  20

Export to Audio File  20

Quick Audio Export  20

Close Project  20

Chapter 4 The Arranger Canvas  21

Create a Track  21

Add or Swap Instruments  21

Arranger Edit Commands  22

Undo  22

Redo  22

Cut  22

Copy  22

Paste  22

Duplicate  22

Duplicate Loop  22

Delete  22

Select All  22

Deselect All  22

Select All Regions in Column  22

Select All Regions in Row  22

Select All Regions in Loop  22

Loop Selected Regions  22

Loops All Regions  22

Mute Selection  23



iv

Loop Playback  23

Note Edit Mode  24

Note Edit Grid Snap Mode  24

BeatForm Edit Mode  25

Drawing in BeatForm Edit mode  25

Painting in BeatForm Edit mode  26

Editing in BeatForm Edit mode  27

Zooming In and Out  28

Zoom to Selection  28

Zoom Out to Maximum  28

Zoom to Default  28

Zoom In To Focus  28

Zoom Out from Focus  28

Zooming Manually  29

Chapter 5 Track Headers  30

Track Headers  30

Track Name  31

Instrument Swap Button  31

Color Bar  31

Volume Fader  31

Solo  32

Mute  32

Record  32

MIDI Input Note Number  32

MIDI Activity Light:  32

Balance Knob  32

Track Header Commands  33

Duplicate  33

Duplicate Track and Contents  33

Delete  33

Rename  33

Select All Tracks  33

Deselect All Tracks  33

Collapse Track  33



v

Collapse All Tracks  33

Change Track Color  33

Sort Tracks By  33

Change Instrument Type…  33

Chapter 6 The Transport Panel  34

Tempo & etronome  34

Rewind to Start  34

Back One Bar/Forward One Bar  34

Play/Stop  34

Recording  35

Playhead Position  35

Follow  35

Loop Mode & Defining a Loop Region  36

Lock Loop to Focus  36

Drag-and-Drop MIDI  36

Note & Velocity  37

Computer MIDI Keyboard Mode & MIDI Map Mode 37

Show/Hide Panel Buttons 37

Chapter 7 Molecule Tools  38

Accent Modifiers  39

Strong, Medium, and Weak  39

Strong 39

Medium 39

Weak 39

Accent Modifier Target Buttons  39

Velocity Sliders  40

Velocity Sliders in Action  40

Groove Sliders  41

Groove Sliders in Action  41

Learn, Apply, Auto, Reset Buttons  42



vi

BeatForm Palette  43

Interacting with individual BeatForms 43

BeatForm Palette List  44

Add and Remove BeatForm Sets  44

Zoom Into the BeatForm Palette  44

How the BeatForm Palette affects other features  45

Randomizer  45

BeatForm Tumbler  45

BeatForm Sequencer  45

BeatForm Editing  45

Randomizer  46

Random BarForm  46

Random BarForm Source  46

Slider Behavior  46

Random BeatForm  47

Random BeatForm Source  47

Repeat BeatForm on Accents  47

Collaborate  48

Collaboration Unit  48

Collaboration Shape  48

Cluster Count  48

Random Velocity and/or Groove  49

GrooveMover  50

Understanding the GrooveMover 50

Move Notes  50

BeatForm Tumbler  51

How the BeatForm Palette affects the BeatForm Tumbler  51

Chapter 8 The Library  52

Instruments  52

Kits  52

Loops  53

Samples  53

Stop Audition Playback  54

Auto-Audition Mode  54



vii

Loop Audition Kit Selection Menu  54

Kit Editor  55

Create a Kit 55

Instrument Editor  56

Loading a Sample  56

Loading Multiple Samples Simultaneously  56

Velocity Map  57

Reset the Velocity Map  57

Auditioning Samples  58

Instrument Audition Bar  58

Adjusting Articulation Boundaries  58

Assigning a MIDI Note to an Instrument  59

Saving an Instrument  59

Chapter 9 The Mixer  60

Channel Strip  60

Track Title  60

MIDI From  60

MIDI To  61

Audio To  61

Instrument Swap  61

Instrument Selector  61

Volume Fader, Balance Knob, Solo, Mute, & Record  62

Master Channel Strip  63

I/O (Input/Output)  63

Master Balance Knob  63

Master Volume  63

Master Mute 63

Metronome Volume 63



viii

Chapter 10 The BeatBuilder  64

How to Use the BeatBuilder  64

BarForm List  65

BarForm Filters  65

Suggested  65

Similar  65

Favorites  65

All  65

BeatBuilder Quick Insert  66

BeatForm Sequencer  67

Sequencer  67

Add BeatForms to the Sequencer 67

Working with the BeatForm Sequencer 68

Surprise Me! 70

Remixer  70

Click the Remixer button to view a comprehensive list of rhythmic possibilities. 70

Chapter 11 The BeatWeaver Rhythm Synthesizer  71

How to Use the BeatWeaver  71

The BarForm & BeatForm Maps  72

BarForm Map  72

Zooming Into the BarForm Map  72

BeatForm Map  73

Deployment Bins  74

Deployment Bins In Action  74

BeatForm Sequence List  75

BeatForm Sequence List Tools  75

Chapter 12 MIDI Mapping 76

MIDI Mapping Mode 76

Assigning Parameters 76

Mappings List 77



ix

MIDI Scripts 78

iConPad Template 78

Overview   78

Setup 79

Device Controls 80

Navigation 80

Beat Building and Sequencing 80

Accent Modifiers  81

Mute 82

Ableton Push Integration  83

Getting started - Setup  83

Setting up Ableton  83

Setting up Liquid Rhythm  84

Setup Push  84

Event Feedback Display  85

64 Pads  85

Pages and Modes  87

Arrange  87

View  88

Accent Modifiers  89

GrooveMover  90

Randomizer  90

BeatForm Tumbler  91

General buttons 92

Undo  92

SHIFT+Undo  92

Delete  92

Double  92

Duplicate  92

New  92

In/Out  92

Mute  92

Solo  92

Select  92

SHIFT  92

TAP TEMPO  92



x

Push General Command pages  93

Midi Designer Template  94

Overview  94

Installation and Setup    95

Installation   95

Wifi connection on Mac  97

Setting up Ableton  100

Views and Modes   102

Main page  102

Navigation and Editing   104

Accent Modifiers   106

BeatForm Tumbler pages   109

BarForm List   111

GrooveMover   112

Randomizer   113

Chapter 13 Help and Troubleshooting  114

On-Screen Help  114

Troubleshooting  114

I can’t hear any music or sound:  114

OSX:  114

I followed the Liquid Clips Installation guide properly but still can’t get it to work  115

Glossary of Terms i

Anatomy of a Molecule i

Examples of BeatForm Notation ii



  

  Liquid Rhythm User Manual - Chapter 1

- 1 -

Chapter 1 Getting Started with Liquid Rhythm 

On behalf of everyone at WaveDNA, thank you for supporting our software! This 
document will help you get Liquid Rhythm up and running, guide you through your 
first steps, and provide a comprehensive  overview of every available feature. 

System requirements & Installation

Mac 
Intel dual-core processor, 2 GB RAM (recommended 4 GB), 6 GB 
hard disk space, OS X 10.6 or  later, Java v. 1.6 or later. 

PC
2 GB RAM (recommended 4 GB), 6 GB hard disk space, Windows XP/Vista/
Windows 7, Java v. 1.6  or later, ASIO-compatible sound card recommended.  

OS X Installation 
1. Navigate to your downloads folder and double-click the LiquidRhythm.dmg file to mount it. 

2. Double-click Install Liquid Rhythm. 

3. Follow the on-screen instructions to complete the installation of Liquid 

Rhythm standalone, VST, AU, RTAS, and Max for Live plugins. 

4. ...and you’re done! Launch Liquid Rhythm standalone or as a plug-

in in any of the DAWs supported by Liquid Rhythm. 

http://www.wavedna.com/daw-compatibility/
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Windows Installation 
1. Double-click the installer file LiquidRhythm.

exe to launch the setup wizard. 

2. Select a destination folder. C:\

Program Files (x86)\WaveDNA\Liquid 

Rhythm is the default destination. 

3. Review your shortcut options. 

4. Click Install to start the installation 

process. Note that you will be prompted 

again to install the VST plugin.

5. Click Finish to close the install window to 

complete the installation. Congratulations, 

you’re now ready to start using Liquid Harmony.

Tip: For both Mac and Windows, the Liquid Rhythm installer automatically installs the 
Liquid Rhythm Max for Live patch for Ableton Live 9. If you don’t have at least Max 
6.1.6 (but not Max 7 yet!!) and Ableton Live 9 installed, you will get a message notifying 
you that the Liquid Rhythm Max for Live plugin was not installed. You’ll be missing 
out on this feature but don’t worry: Your install will still complete successfully. For 

more information on the Liquid Rhythm Max for Live patch, visit wavedna.com.   
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Nomenclature  
The purpose of this guide is to show you every available feature in Liquid Harmony. To get 
the most out of it, please read this description of the computer lingo used throughout: 

OS X & Windows Keyboard Commands Terminology 
In the Liquid Rhythm User Manual, keyboard shortcuts will be presented using a 
combination of modifier and keyboard keys. Note that Apple and Windows keyboards have 
different names for modifier keys  that serve the same function in Liquid Rhythm.
  
For your reference and convenience, modifier keys will always be presented in the order of 
[OS X]/[Win] where OS X refers to Apple keyboards and Win refers to Windows keyboards. 

Modifier Keys are: 

 » [command]/[ctrl]

 » [option]/[alt] 

 » [shift]

 » [control] **OS X only** 

Mouse Terminology 
 » Click: to hover the mouse arrow over an object, menu item, 

etc., and single-click with the left mouse  button.  

 » Double-click: to hover the mouse arrow over an object, menu item, 

etc., and double-click with the left  mouse button.  

 » Right-Click: to hover the mouse arrow over an object and single-click with the right mouse 

button. Right-clicks typically open pop-up or pull-down menus for that specific clickable object.  

 » Drag: to click on an object and hold down the mouse button while moving the 

mouse.  To stop the drag from occurring, release the mouse button.   

 » Drag-and-Drop: to click on an object it, hold the button down while moving 

the mouse, and releasing the mouse button to complete the action.  
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Welcome Screen 
A Welcome Screen greets you when 
you launch Liquid Rhythm. The 
following is a brief description of the 
helpful features found there.

Watch Quickstart Video 
 » Launches a Quickstart Video to get 

you acquainted with some of the 

features in Liquid Rhythm quickly. 

Read Quickstart Guide 
 » Opens the Quickstart Guide PDF. 

Start Guided Walkthrough 
 » Launches a comprehensive and 

interactive walkthrough of some of 

the features found in Liquid Rhythm. 

Show On Startup 
 » Deselect this option to prevent the 

Welcome Screen from opening each 

time you launch Liquid Rhythm. 

Close 
 » Closes the Welcome Screen window. 
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Settings 
When you launch Liquid Rhythm for the first 
time, default driver and audio input/output 
settings will be loaded. Click on LiquidRhythm 
> Preferences… (OSX) or use the [command]/
[ctrl]+[,] key command to open the Settings 
window and configure audio preferences. 

Audio 

Audio 
This option turns audio output on and off. 

Driver 
Lets you select the audio interface you prefer to use. 

Input Device 
Lets you select the audio interface you prefer to use for audio input. 

Output Device 
Lets you select the audio interace you prefer to use for audio output. 

Sample Rate 
All the instruments in Liquid Rhythm are recorded at 44100, so unless you are 
looking for a very specific sound, best not tinker with this option. 

Tip: In the event that your audio interface or MIDI device doesn’t appear, 
it may be possible you haven’t set up your device’s drivers yet. Consult 
the manufacturer’s website for details on installing drivers. 
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Look and Feel 
Half the fun of setting up new audio 
software is customizing its appearance. 
In Liquid Rhythm, Look and Feel can be 
customized from the Settings window. 
 
To access the Look and Feel window: 

1. Click Options > Settings or 

press [command]/[ctrl]+[,] 

2. Click the Look and Feel tab.

Try playing with these settings to see 
which configuration works best for you 
or use our Low Quality Presets and High 
Quality Presets buttons to quickly swap 
between contrasting visual experiences. 

Library 
One of the first things you’ll want to do is download all the available drum kits 
featured in Liquid Rhythm (you’ve already paid for them, after all)! Click the Download 
Additional Instruments button in the Library tab to select and download them all. 
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Devices 

Device Names 
Device Names is a list of all the 
external (or internal) MIDI devices 
recognized by your computer. 

Options 
Use the Options adjacent the Device 
Names list to set the behaviour of 
the connected MIDI devices: 

MIDI Hit 
Means that incoming MIDI Note messages (the kind drum pads 
or the keys on a piano send) will be received. 

MIDI Mapping 
Means that any MIDI control change (MIDI CC) messages (the kind that a 
fader or knob on your MIDI controller send) will be received. 

A good way to distinguish between the two is this: 

 » MIDI Hit = A note being played 

 » MIDI Mapping = A UI element on Liquid Rhythm being controlled. 

Note that you can also set the behaviour to Both or None. 
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How to connect a MIDI Device to your computer 
There are two ways to connect a MIDI device to your computer: 

1. Connecting an external MIDI device directly via USB: 

a. Many new MIDI devices connect to your computer with a USB cable and have 

their own drivers. Make sure your MIDI device is connected to your computer 

and recognized by your operating system before launching Liquid Rhythm.

2. Connecting an external MIDI device through a MIDI interface: 

a. Once you’ve connected your MIDI interface, make the following physical 

connections between your external MIDI device and MIDI interface: 

i. The MIDI Out on your external device is connected to the MIDI IN on your MIDI interface. 

ii. The MIDI IN on your external device is connected to the MIDI OUT on your MIDI interface. 

Tip: To ensure you have followed all the necessary steps and installed all the necessary 
drivers to enable compatibility between your computer and MIDI interface, please 
reference the MIDI interface manufacturer’s documentation or website. 

Testing Your External MIDI Controller 
The MIDI Note and Vel indicators to the right of the toolbar will display MIDI 
values Liquid Rhythm receives from an external device. With your MIDI device 
connected and turned on, press a key on your MIDI keyboard, drum pad or 
control surface to test connectivity and monitor it using the indicators. 
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Chapter 2 Integrating Liquid Rhythm with your 
Digital Audio Workstation 

The Liquid Rhythm VST, AU, and RTAS plug-ins, along with the Max for Live patch, allow you to 
use Liquid Rhythm within your preferred digital audio workstation (DAW) in OS X or Windows. 

A variety of workflows exist:

 » Stereo Plug-in is the most basic form of the Liquid Rhythm VST/AU/

RTAS plug-in. It outputs a stereo signal through channels 1-2 

 » Multi-ouput Plugin is a version of the plug-in capable of outputting 8x stereo 

channels. This is useful for doing things like implementing a unique FX chain for only 

a snare drum while treating the kick with a different set of FX, for example. 

 » Interplug-in MIDI Routing is a zany setup we like to use around these parts. 

Basically, Liquid Rhythm becomes a software-based MIDI controller capable of 

sending performance information (MIDI notes) to other VST plug-ins. 

Note that only the VST plug-in protocol makes this possible, so if you 
try to use AU, your DAW might crash. Use at your own risk! 

For your convenience, step-by-step plug-in loading and MIDI routing 
procedures have been prepared for all tested DAW’s.

If you notice any DAWs we haven’t covered in this chapter, please contact support 
at info@wavedna.com. Our testers are always willing to try out new software! 

Tip: Please note that there are occasionally multiple ways to achieve the same goal when using 
a DAW. The following steps describe only one way of loading a plug-in or solving for a desired 
workflow; other ways might exist, and we encourage you to explore them. Exploration is a part of 
becoming familiar, confident, and productive with any of the softwares we mention in this chapter =)

Also, keep in mind that these instructions don’t include creating a project, assiging VST/AU/
RTAS plug-in folders, or basic audio/MIDI setup of any kind. For more information on how to 
create a project using your host DAW software, please consult their help documentation. 

The following is a list of all tested software and the plug-in loading steps for each: 
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OS X

Ableton Live 8 

Stereo plug-in steps:
1. Navigate to your installed plug-ins by clicking View > Browser > Plug-In Devices. 

2. Ableton Live 8 is compatible with both VST and AU plug-ins. Navigate to either 

Audio Units > WaveDNA > LiquidRhythm or VST > Local > LiquidRhythm. 

3. Double-click LiquidRhythm plug-in onto the MIDI track you just created. 

Tip: If you want to swap LiquidRhythm plug-in for a plug-in you have already loaded in a MIDI 
track, select the MIDI track and double-click LiquidRhythm in the Plug-In Devices browser. 

Ableton Live 9 

Stereo plug-in steps:
1. Create a MIDI track by clicking Create > Insert MIDI Track or pressing [command]+[shift]+[T]. 

2. Click View > Show Browser or press [command]+[option]+[B] to view the 

contents of the Browser (the pane on the left of the screen). 

3. Under Categories, click plug-ins. 

4. Navigate to either Audio Units > WaveDNA > LiquidRhythm or VST > LiquidRhythm and 

drag and drop the plug-in onto the MIDI track you just created to launch Liquid Rhythm. 

Cubase 7

Stereo plug-in steps:
1. Click Devices > VST Instruments.

2. In the VST Instruments window, click on an empty slot (indicated 

by “No Instrument”) and select Liquid Rhythm.

3. When asked “Do you want to create a MIDI track assigned to the plugin 

‘Liquid Rhythm’?” click Create (it doesn’t hurt to have!) 

Tip: You can also click Project > Add Track > Instrument... to load Liquid Rhythm, but 
using the method described above makes creating multiple outputs very easy.
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Logic Pro 9 

Stereo plug-in steps:
In Logic Pro 9...

4. Create a Software Instrument track by either clicking Track 

> New… or press [command]+[option]+[N]. 

5. Note the corresponding channel strip for the track you just created in the 

pane to the left of the arrange page. Above the volume fader, there are two 

buttons beneath the label I/O. Click the first of the two buttons to reveal a 

dropdown list with all the available plug-ins in your plug-in library. 

6. Scroll to the bottom of the list, and navigate to AU Instruments > WaveDNA > 

LiquidRhythm > Stereo to load a stereo instance of the Liquid Rhythm plug-in.

Multi-output plug-in steps:
In Logic Pro 9...

1. Create a Software Instrument track by either clicking Track 

> New… or press [command]+[option]+[N]. 

2. Note the corresponding channel strip for the track you just created in the 

pane to the left of the arrange page. Above the volume fader, there are two 

buttons beneath the label I/O. Click the first of the two buttons to reveal a 

dropdown list with all the available plug-ins in your plug-in library. 

3. Scroll to the bottom of the list, and navigate to AU Instruments > WaveDNA > LiquidRhythm 

> Multi Output (8xStereo) to load a mulit-output instance of Liquid Rhythm.

4. Click the Mixer button on the bottom left of the Arranger panel to view the mixer.

5. Press the + button to the left of the Mixer panel to open the 

New Auxiliary Channel Strips dialogue box.
In the New Auxiliary Channel Strips dialogue box ...

6. In the Number field, enter 7.

7. Change the Format to Stereo.

8. Click Create.
In Logic Pro 9’s Mixer panel ...

9. Seven new tracks will have appeared in Logic Pro 9’s Mixer, each capable of 

receiving stereo feeds from Liquid Rhythm’s multiple outputs. In each Aux track, 

click the first bar under the I/O label and assign Liquid Rhythm’s outputs to the 

Auxiliary tracks’ inputs in ascending order. For example, Aux 1 will be assigned to 

“LiquidRhyth 3-4”, Aux 2 will be assigned to “LiquidRhyth 5-6”, and so on. 
Tip: Liquid Rhythm (along with every other audio unit plug-in that ouputs multiple 
stereo tracks) reserves output 1-2 for the instrument track containing the plug-in. 
This means that you’ll be grouping one Instrument track with seven auxiliary tracks 
for an 8x stereo setup in Logic Pro 9. Also note that the name of the Instrument 
containing Liquid Rhythm will simply be “Inst 1” if you haven’t renamed the track. 
In Liquid Rhythm...

10. Load individual instruments or an entire Kit from Liquid Rhythm’s Library.
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11. Open the Mixer by pressing [command}+[5] or pressing 

the Mix button on the right of the toolbar.

12. Right-click the first channel strip and select Set Ascending Channel Audio Routing to quickly 

send the first eight tracks in Liquid Rhythm to the eight available tracks in Logic Pro 9.

13. To set the output manually, first press the I/O button on the Master Channel Strip.

14. Click the Audio To dropdown menu on each track you want to route to your 

available tracks in Liquid Rhythm and select the desired outputs.

Logic Pro X

Stereo plug-in steps:
In Logic Pro X...

1. Click Track > New Software Instrument Track or use the [command]+[option]+[N] key 
command to open the New Track dialogue box and create a Software Instrument. 

2. Note the corresponding channel strip for the Instrument track you just created in the 
Inspector (on the left of the screen). Hover over the Input bar (beneath MIDI FX and 
above Audio FX) and click the Up/Down arrows on the right of the bar to access the drop-
down menu containing all the available software instruments you have installed.

3. Scroll to AU Instruments > WaveDNA > Liquid Rhythm > Stereo to 
load a stereo instance of the Liquid Rhythm plug-in. 

Multi-output plug-in steps:
In Logic Pro X...

1. Create a Software Instrument track by either clicking Track > New Software 

Instrument Track or press [command]+[option]+[N] to open the New 

Track dialogue box and create a Software Instrument track.

2. Note the corresponding channel strip for the track you just created in the Inspector 

pane to the left of the arrange page. Hover over the Input bar (beneath MIDI FX and 
above Audio FX) and click the Up/Down arrows on the right of the bar to access the drop-
down menu containing all the available software instruments you have installed.

3. Scroll to the bottom of the list, and navigate to AU Instruments > WaveDNA > LiquidRhythm 

> Multi Output (8xStereo) to load a mulit-output instance of Liquid Rhythm.

4. Click the Mixer button on the left of the toolbar to view the mixer.

5. With the Mixer in focus, use the [command]+[option]+[N] key command 

to create seven New Auxiliary Channel Strips (one at a time).

6. In each Aux track, click the bar in the Input row and assign Liquid Rhythm’s outputs 

to the Auxiliary tracks’ inputs in ascending order. For example, Aux 1 will be assigned 

to “LiquidRhyth 3-4”, Aux 2 will be assigned to “LiquidRhyth 5-6”, and so on. 
Tip: Liquid Rhythm (along with every other audio unit plug-in that ouputs multiple 
stereo tracks) reserves output 1-2 for the instrument track containing the plug-in. 
This means that you’ll be grouping one Instrument track with seven auxiliary tracks 
for an 8x stereo setup in Logic Pro 9. Also note that the name of the Instrument 
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containing Liquid Rhythm will simply be “Inst 1” if you haven’t renamed the track. 
In Liquid Rhythm...

7. Load individual instruments or an entire Kit from Liquid Rhythm’s Library.

8. Open the Mixer by pressing [command}+[5] or pressing the Mix button on the right of the toolbar.

9. Right-click the first channel strip and select Set Ascending Channel Audio Routing to quickly 

send the first eight tracks in Liquid Rhythm to the eight available tracks in Logic Pro 9.

10. To set the output manually, first press the I/O button on the Master Channel Strip.

11. Click the Audio To dropdown menu on each track you want to route to your 

available tracks in Liquid Rhythm and select the desired outputs.

Presonus Studio One 2 

Stereo plug-in steps:
In Studio One 2...

1. Click View > Show Instruments. 

2. Click WaveDNA in the Instruments pane on the left to reveal the plug-ins. 

3. Drag-and-drop either the VST or AU Liquid Rhythm plug-in onto the blank 

arranger to create an instrument track and launch Liquid Rhythm. 
Tip: You might (generally) enjoy more stability with the VST plug-in.

Multi-output plug-in steps:
 In Studio One 2...

1. Click View > Show Instruments. 

2. Click WaveDNA in the Instruments pane on the left to reveal the plug-ins. 

3. Drag-and-drop either the VST or AU Liquid Rhythm plug-in onto the blank 

arranger to create an instrument track and launch Liquid Rhythm. 
Tip: You might (generally) enjoy more stability with the VST plug-in.

4. The Instrument Editor should have appeared after loading Liquid 

Rhythm. If it didn’t, click Track > Show Instrument Editor.
In the Instrument Editor...

5. Click the CH button on the toolbar to reveal the channel routing 

options for the Liquid Rhythm instrument.

6. Click all the checkboxes to activate them. 
In Liquid Rhythm...

7. Load individual instruments or an entire Kit from Liquid Rhythm’s Library.

8. Open the Mixer by pressing [command}+[5] or pressing the Mix button on the right of the toolbar.

9. Right-click the first channel strip and select Set Ascending Channel Audio Routing to quickly 

send the first eight tracks in Liquid Rhythm to the eight available tracks in Logic Pro 9.

10. To set the output manually, first press the I/O button on the Master Channel Strip.

11. Click the Audio To dropdown menu on each track you want to route to your 

available tracks in Liquid Rhythm and select the desired outputs.
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Interplug-in MIDI Routing
In Studio One 2...

1. Follow the Stereo plug-in steps to load the Liquid Rhythm plug-in.

2. Follow the same Stereo plug-in steps to load a different VST or AU plug-

in (such that yoiu have two different plug-ins loaded).

3. In the Track Header belonging to the plug-in you want to control using Liquid 

Rhythm, change Instrument Input from “All Inputs” to “LiquidRhythm”.

4. In the adjacent MIDI channel drop-down menu, select channel 10. 

5. Click View > Console.
In the Console...

6. Mute Liquid Rhythm (to isolate the track being controlled 

with the MIDI Liquid Rhythm is sending).

7. Click the Monitor button, indiacted by a blue speaker, on the track you want to send MIDI to. 

Pro Tools 10 

Stereo plug-in steps:
1. Create a new track by either clicking on Track > New… or press [command]+[shift]+[N]. 

2. In the dialogue box that appears, adjust the options for your new track from Mono 

to Stereo and change the type of track from Audio Track to Instrument Track. 

3. Click the Create button. 

4. Launch the Mix window by either clicking Window > Mix or 

using the [Command]+[=] key command. 

5. Locate the Instrument track you just created; it will most likely be labeled Inst 

1. At the very top of the track, you will find the Inserts A-E panel. Click the first 

empty space to reveal the dropdown menu and click on multichannel plug-in > 

Instrument > LiquidRhythm (Stereo) to launch Liquid Rhythm RTAS plug-in. 

Tracktion 5

Stereo plug-in steps:
1. Create a new filter by clicking-and-dragging the blue New Filter button 

(found at the top right of the screen) onto any track’s output path.
Tip: This has been done properly when the output path location glows red. For more 
help on creating filters in Tracktion, please consult their help documentation.

2. In the drop-down menu that appears, scroll down to Library/

Audio/Plug-Ins/VST and select LiquidRhythm.
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Windows 
The Liquid Rhythm VST plug-in allow you to use Liquid Rhythm within your preferred 
digital audio workstation (DAW) in Windows. For your convenience, step-by-
step plug-in loading procedures have been prepared for all tested DAW’s. 

Tip: Please note that there are always multiple ways to achieve the same goal when 
using a DAW. The following steps describe one way of loading a plug-in; other ways 
exist, and we encourage you to explore them. Also, keep in mind that these instructions 
don’t include creating a project. For more information on how to create a project 
using your host DAW software, please consult their help documentation. 

The following is a list of all tested software and the plug-in loading procedures for each: 

Ableton Live 9 
1. Create a MIDI track by clicking Create > Insert MIDI Track or pressing [ctrl]+[shift]+[T]. 

2. Click View > Show Browser or press [ctrl]+[alt]+[B] to view the contents 

of the Browser (the pane on the left of the screen). 

3. Under Categories, click plug-ins. 

4. Navigate to the LiquidRhythm plug-in and double-click it or drag and drop 

it onto the MIDI track you just created to launch Liquid Rhythm. 
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Max for Live patch Exclusive Features 
When using Liquid Rhythm as a Max for Live patch, you’ll notice that certain UI elements 
are non-existent and that some new features have appeared. In this section, we are 
going to discuss features exclusive to Liquid Rhythm’s Max for Live patch. 

1. Clip Controls 
Clip Controls give you transport controls for 
the Ableton Clip you are working on right in 
Liquid Rhythm. Play, Stop, Fast Forward, or 
Rewind to your heart’s content. Note that the 
Fast Forward and Rewind buttons move the 
playhead forward or backward by one bar. 
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2. Refresh from Live 
Liquid Rhythm will automatically refresh the data 
you manually input into Live clips. However (stay 
with me here), if you are using an external MIDI 
device (like a drum pad or keyboard) to input 
notes into Live while Liquid Rhythm is in focus, 
Liquid Rhythm will not update automatically. 

Click the Refresh from Live button to update Liquid 
Rhythm’s arranger with the contents of a Live clip you have altered using an external MIDI device. 

3. Color-Coordinated Arranger 
You’ll notice that when you select clips in Live to 
edit with Liquid Rhythm, the Arranger becomes 
engulfed by the color of the clip being edited. 
Take this striking hot pink facade, for example: → 
Isn’t it a lovely solution to the problem: 
“How will I keep track of which clip I’m 
editing?” It’s the little things... *sigh 

4. Clip Selector 
The Clip Selector is a list containing shortcuts 
to clips in your Live session view. To use it: 

1. Select a clip in any MIDI track (in Live) and 

it’s automatically added to this list. 

2. Double-click a Recent clip to view 

its contents in Liquid Rhythm. 

Notice that the colors of the 
Clips in your Live MIDI track 
match those in the Clip Selector to help you keep track. 

While working through your session, you’ll notice that this list can quickly grow. 
Drag-and-drop clips you use the most often into the Saved tab. 
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As you already know, selecting a clip in Live loads its contents automatically 
into Liquid Rhythm’s Arranger. To edit one clip exclusively: 

1. Activate Lock Mode. You are now free to select and edit other clips in 

Live while keeping Liquid Rhythm focused on a specific clip. 

2. When you’re ready to edit another clip, double-click it from 

the Clip Selector list or deactivate lock mode. 

5. Loop Library 
The Loop Library contains a wealth of MIDI 
loops you can load into Liquid Rhythm’s 
arranger and use with any Ableton Drum 
Rack or 3rd party rhythm synth. 

Use the Library Filters or Search Dialogue to 
narrow the results to your heart’s content. 

To load a Loop, do either of the following: 

 » Drag-and-drop a Loop onto the Arranger. 

 » Double-click a Loop. 
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Chapter 3 Project File Controls 

Project File Commands 

New Project 
To create a new project, perform 
one of either command: 

 » Click File > New. 

 » Press [command]/[ctrl]+[N] 

Open... 
To open an existing project, perform 
one of either command: 

 » Click File > Open... 

 » Press [command]/[ctrl]+[O] to 

launch the Open dialog box, 

navigate to your project file, 

and either double-click the file or select the file and click Open. 

Open Recent 
To open a recent project: 

 » Hover your mouse over File > Open Recent to view a drop-down menu containing 

your most recent Liquid Rhythm projects. Click an entry to load it. 

Save 
To save a new or existing project file: 

1. Click File > Save or press [command]/[ctrl]+[S] to launch the Save dialog box. 

2. Enter a name for your project and specify a location on your hard drive to save it. 

3. Click Save to confirm. 

Save As... 
To save a new version of an existing project file: 

1. Click File > Save As or press [command]/[ctrl]+[shift]+[S] to launch the Save As dialog box. 

2. Enter a name for your project and specify a location on your hard drive to save it. 

3. Click Save to confirm. 

Consolidated Save 
To save a project file with Instrument Editor assets, including external audio samples: 

 » Click File > Consolidated Save. 

Import MIDI File... 
To import an existing MIDI file: 

1. Click File > Import MIDI File. 
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2. Navigate to the MIDI file you want to import. 

3. Choose a General MIDI Kit to load with the file. 

4. Click Open to import the MIDI file. 

5. Tip: For optimized use with a percussive MIDI performance, ensure that Only General MIDI 

Percussion Note Numbers and Only Notes in MIDI Percussion Channel (10) are selected. 

Export to MIDI File... 
To export your project as a MIDI file: 

1. Click File > Export to MIDI File. 

2. Name the MIDI file in the File Name dialog box. 

3. Click Save to export to MIDI. 

Tip: All the drum and percussion tracks in your Liquid Rhythm file are 
automatically mapped using the General MIDI Standard. 

Quick MIDI Export 
 » Export current tracks to a MIDI file at the last exported location. 

 » [command]/[ctrl]+[shift]+[F] 

Export to Audio File 
With Liquid Rhythm standalone, you can export your project as a WAV or AIFF audio file. To do so: 

1. Define the Start and End points of your audio file using the Loop Region.

2. Click File > Export to Audio File to open the Export Audio window. 

3. Enter a name for your audio file in the Save As dialog box. 

4. Select a destination to save your file. 

5. Choose either WAV or AIFF from the File Type drop-down menu. 

6. Choose the bit depth from the Bit Depth drop-down menu. 

7. Select: 

8. Master Mix to render every track in your project file to audio. 

9. Individual Tracks to select specific tracks from the window to the left 

10. Click Export to start rendering to audio. 

Quick Audio Export 
 » Export current tracks to a WAV or AIF file using the latest settings at the latest exported location. 

 » [command]/[ctrl]+[shift]+[B] 

Close Project 
 » Close the current project and start a new project. 

http://en.wikipedia.org/wiki/General_MIDI
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Chapter 4 The Arranger Canvas 

Liquid Rhythm’s arranger is a digital canvas; what you create with it is entirely up to 
you. The grid is designed to help you organize your ideas as you create them: the lines 
running vertically through the grid represent divisions in time, while the lines running 
horizontally separate each track. The Playhead (the thin vertical line that moves when 
you press play) indicates the current frame during playback and zoom processes. 
The following section will walk you through the elements of the arranger. 

Create a Track 
To create an empty track, perform any of the following actions: 

 » Right-click anywhere in the arranger grid and select Create Track from the drop-down menu. 

 » Click Insert > Create Track 

 » Press [command]/[ctrl]+[T] 

 » Double-click an Instrument in the library. 

Add or Swap Instruments 
To add or swap voices into the newly created track, simply drag-and-
drop Instruments from the Library onto the Channel Header. 
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Arranger Edit Commands 
There are a number of useful commands we 
hope will make your experience editing in the 
arranger a great one. They can be found in 
the Edit menu, but most of them are mapped 
to keyboard commands as well. They are: 

Undo 
 » [command]/[ctrl]+[Z] 

Redo 
 » [command]/[ctrl]+[shift]+[Z] 

Cut 
 » [command]/[ctrl]+[X] 

Copy 
 » [command]/[ctrl]+[C] 

Paste 
 » [command]/[ctrl]+[V] 

Duplicate 
 » [command]/[ctrl]+[D] 

Duplicate Loop 

Delete 
 » [delete]/[backspace] 

Select All 
 » [command]/[ctrl]+[A] 

Deselect All 
 » [command]/[ctrl]+[shift]+[A] 

Select All Regions in Column 

Select All Regions in Row 
 » [command]/[ctrl]+[shift]+[T] 

Select All Regions in Loop 
 » [command]/[ctrl]+[shift]+[L] 

Loop Selected Regions 
 » [command]/[ctrl]+[L] 

Loops All Regions 
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Mute Selection 
 » [command]/[ctrl]+[shift]+[M] 

Loop Playback 
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Note Edit Mode 
Use Note Edit Mode to draw MIDI notes 
(individually or in clusters) directly onto the 
arranger canvas with your mouse. Enable it 
by performing any of the following actions: 

 » Click the Note Edit Mode button. 

 » Press [command]/[ctrl]+[E] 

 » Right-click anywhere in the 

arranger and select Note Edit Mode from the dropdown menu. 

There are two distinct tools in Note Edit Mode: 

 » Pencil Tool allows in-place editing of single notes. Single-

click to insert a note, double-click to delete. 

 » Paint Tool lets you input multiple notes simultaneously. 

Simply click and drag across regions to use it. 

Note Edit Grid Snap Mode 
Enable Note Edit Grid Snap Mode to force 
the notes you enter using Note Edit Mode to 
quantize to the grid. By default, this feature is 
on. To toggle it on or off, press the Note Edit Grid 
Snap Mode button above the track headers. 

To set the Note Edit Grid Resolution, select 
the desired value from the drop-down menu 
directly to the right of the snap to grid button. 
Note that you can toggle the Triplet grid. 
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BeatForm Edit Mode 
The BeatForm Edit feature lets you draw or paint 
with BeatForms (or clusters of notes) directly on the 
Arranger. To activate it, click the BeatForm Edit button. 

Drawing in BeatForm Edit mode 
When BeatForm Edit mode is activated, notice that the Note 
Edit Grid Resolution menu becomes the BeatForm Paint menu. 

 » Select any BeatForm from this menu.

 » Click in the Arranger to draw with it. 



  

  Liquid Rhythm User Manual - Chapter 4

- 26 -

Painting in BeatForm Edit mode 
You can also click-and-drag across the 
Arranger to paint with BeatForms. Make sure 
BeatForm Edit mode is activated, then: 

1. Right-click the Pencil Tool. 

2. Select the Paint Tool from 

the drop-down menu. 

3. Select a BeatForm from the 

BeatForm Paint menu. 

4. Click-and-drag across 

a track in the Arranger to paint with the selected BeatForm. 
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Editing in BeatForm Edit mode 
While in BeatForm Edit mode, there are a number of commands you 
can use to edit the BeatForms you draw onto the Arranger. 

 » Press-and-hold [shift] and click-and-

drag to multiselect BeatForms. 

 » Click-and-drag BeatForms 

to move them around. 

 » Right-click on BeatForms to 

swap them for other ones. 

 » Click-and-drag the velocity bars above 

a BeatForm(s) to adjust it’s velocity. 

 » Double-click BeatForms to delete them. 
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Zooming In and Out 
There are a variety of ways to zoom in 
and out of the arranger canvas: 

Zoom to Selection 
 » select a region(s) and click View 

> Zoom to Selection 

 » [command]/[ctrl]+[R] 

Zoom Out to Maximum 
 » click View > Zoom Out to Maximum 

 » [shift]+[command]/[ctrl]+[R] 

Zoom to Default 
 » click View > Zoom to Default 

 » [command]/[ctrl]+[B] 

Zoom In To Focus 
 » select a 

region(s) and click View > Zoom In to Focus 

 » [command]/[ctrl]+[=] 

Zoom Out from Focus 
 » select a region and click View > Zoom Out from Focus 

 » [command]/[ctrl]+[-] 
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Zooming Manually 
Use the following tools to manually adjust 
the arranger canvas view with simple click 
and drag gestures using your mouse: 

 » Overview Scroll and Zoom bar 

 » Zoom In to Focus/Zoom Out from Focus 

 » Ruler Bar 
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Chapter 5 Track Headers 

Track Headers 
Each track you create in Liquid Rhythm has a 
corresponding track header in the arranger 
canvas and a channel strip in the Mixer panel. 
You use track headers to adjust the 
volume and balance of tracks, mute or 
solo them, or arm them for recording. 

Track headers also contain valuable 
information about what kind of drum 
Instrument is associated with it. 

This chapter is all about Track Headers and 
what you can do with them in Liquid Rhythm. 
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1. Track Name 
 » Displays the name of the instrument 

currently loaded into the track. 

 » To rename the track, click on the 

track name and type a new name. 

 » To manually select a different instrument, 

click the dropdown menu and choose 

an instrument from the list. 

2. Instrument Swap Button 
 » Click the Instrument Swap Button to swap any sound in the Library for the one you have 

presently loaded. The track name updates to reflect the new instrument loaded. How to use it: 

 » First, open the Library by pressing [command]/[ctrl]+[1] 

 » Activate Swap Mode for the track whose Instrument you want to swap. 

 » Single-click any instrument in the Library and it will swap into the track. 

 » Note that activating Swap Mode on a track causes the Library 

to filter instruments specific to that track. 

 » Swapping is a great way to audition instruments during playback! 
Tip: Another way to quickly swap instruments is to drag-and-
drop them from the Library onto the Channel Header. 

3. Color Bar 
 » Located at the right of the track header, it denotes what instrument type 

the instrument is. To pick another color, right-click on the Channel Header 

and select Change Track Color from the dropdown menu. Select a color 

using any of the three tabs and click Ok to confirm your selection. 

 » You can also click the Color Bar to fold the track. 

4. Volume Fader 
 » Controls the track’s volume. Click the volume fader and move the mouse left or right to 

set the volume for your track. Command-click to return the fader to its default value. 
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5. Solo 
 » Click the button labeled S to isolate 

the track(s) you want to hear without 

the rest of the project playing. 

6. Mute 
 » Click the button labeled M to mute the track(s) you do not want to hear. 

7. Record 
 » Click the button labeled R to write any MIDI input received from the 

computer or external device to the selected track(s). 
Tip: Press and hold [shift] while clicking any Mute or Record button to affect every channel. 

8. MIDI Input Note Number 
 » Indicates the MIDI note value associated with the track. Click the value and drag 

the mouse up or down to map the instrument to another MIDI note. 

9. MIDI Activity Light: 
 » Click this button to audition the instrument loaded in the track. 

10. Balance Knob 
 » Varies the relative level of the left and right channels in the track. Click on the knob and drag the 

mouse up and down to change its value; command-click to return the knob to its default value. 
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Track Header Commands 
Right-click a track header (or select multiple 
track headers using [command]+click or 
[shift]+click) to reveal a drop-down menu 
containing the following commands: 

Duplicate 
 » Makes a duplicate of the selected track(s) 

but not the region(s) within the track(s). 

Duplicate Track and Contents 
 » Makes a duplicate of the selected track(s) 

and the regions within it/them. 

 » Key command: [command]/[ctrl]+[D]. 

Delete 
 » Removes the selected track(s) 

 » Key command: [delete] 

Rename 
 » Changes the name of the selected track(s). 

Select All Tracks 
 » Highlights all the track headers. 

 » Key command: [command]/[ctrl]+[A]. 

Deselect All Tracks 
 » Removes highlighting from all the track header(s). 

 » Key command: [command]/[ctrl]+[shift]+[A]. 

Collapse Track 
 » Minimizes the selected track header(s). 

Collapse All Tracks 
 » Minimizes all the track headers. 

Change Track Color 
 » Changes the color of the Color Bar associated with the selected track header(s). 

Sort Tracks By 
 » Arranges the tracks by Name, MIDI Note, Instrument type. 

Change Instrument Type… 
 » Allows changing of the instrument type associated with selected track(s). 

Tip: The BeatSeeker uses instrument types to suggest results, so use this 
option to help organize custom samples from your library! 
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Chapter 6 The Transport Panel 

Playback, tempo, loop region controls, quick controls, and the show/
hide buttons for all the panels can be found in the Transport Bar. 

Tip: Playback and tempo will be synced to your host DAW’s transport 
in plug-in mode and disabled in Liquid Rhythm. 

1. Tempo & etronome 
Click the Metronome button to activate Liquid 
Rhythm’s click track in standalone mode. The 
tempo window displays the current project’s 
beats per minute (BPM). Adjust the tempo by 
performing any of the following actions: 

 » Click the Tempo window 

and drag the mouse up or 

down to increase or decrease the tempo value. 

 » Click the Tempo window and enter a numerical value using your keyboard. 

 » Click the Tempo window and press the up and down cursors on 

the keyboard to increase or decrease the tempo. 
Tip: Note that in plug-in mode, tempo controls in Liquid Rhythm are disabled. 

2. Rewind to Start 
 » Rewind to the beginning of the arrangement. 

3. Back One Bar/Forward One Bar 
 » Moves the Playhead back or forward by one bar. 

4. Play/Stop 
 » Use these buttons to start and stop playback. 

 » Key command: [spacebar] 



  

  Liquid Rhythm User Manual - Chapter 6

- 35 -

5. Recording 
To record a beat to Liquid Rhythm’s arranger canvas: 

1. Turn Record Mode on by clicking the Record 

Mode button on the transport panel. 

2. Arm a track(s) by pressing the R 

button on the track header. 

3. Press the Play button in 

the transport panel or the [spacebar] to start recording. 

Tip: You can arm every track in the arranger by pressing [shift] and 
clicking the Record button within the track header. 

6. Playhead Position 
The Playhead is the thin vertical line that scrolls to indicate what regions and notes 
are being read during playback. The Playhead Position window displays where the 
Playhead is using a three-digit numerical value denoting bars.quarters.sixteenths. For 
example, 2.3.1 means that the Playhead is at the 1st sixteenth note of the 3rd quarter 
note of the 2nd bar. To manually adjust the location of the Playhead, either: 

 » Click on the first value (bar) in the Playhead Position window, enter a number 

using the numbers on your keyboard, and press [return]/[enter]. 

 » Click on the first value in the Playhead Position window and drag the 

mouse up or down to increase or decrease the value. 

7. Follow 
 » Press the Follow button to scroll through the arranger canvas during 

playback. When Follow is disabled, the view on the Arrange Page will 

stay in the same position when the Playhead goes out of view. 

 » Key command: [command]/[ctrl]+[F] 

You can adjust the behavior of the Follow feature. To do so: 

1. Click Options > Settings or press [command]/[ctrl]+[,] to open the Settings menu. 

2. Click the Look and Feel tab at the top of the Settings window. 

3. Click the Playhead Follow Behavior dropdown menu to select from either Scroll or Page. 
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8. Loop Mode & Defining a Loop Region 
Loop mode enables you to 
loop a specific section of your 
beat. Click the Loop Toggle 
button to enable Loop Mode. 

There are two ways to 
define the Loop Region: 

1. Using the Loop Region bar, 

a. Resize by clicking the edge(s) of the Loop 

Region bar and dragging the mouse 

left or right to extend the region. 

b. Reposition by clicking the center 

of the Loop Region bar and 

dragging the mouse left or right.

2. Using the Loop Length and 

Loop Start windows, 

a. Resize by clicking the Loop Length window and either dragging the 

mouse up or down or manually entering a value using the numbers 

on your keyboard and pressing [return]/[enter] to confirm. 

b. Reposition by clicking the Loop Start window and either dragging the 

mouse up or down or manually entering a value using the numbers 

on your keyboard and pressing [return]/[enter] to confirm. 

9. Lock Loop to Focus 
Once you’ve defined a loop region, click the Lock Loop to Focus 
button to automatically loop the bar presently selected. 

10. Drag-and-Drop MIDI 
Click-and-drag this button onto another DAW’s arranger to instantly copy/
paste the MIDI performance in Liquid Rhythm’s arranger. 

You can also drag-and-drop to your desktop to save the contents 
of Liquid Rhythm’s arranger as a MIDI file.
 
Tip: Since Liquid Rhythm’s instruments are mapped using General MIDI, dropping the 
resulting MIDI file into another drum/percussion/beat plug-in will have great results! 
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11. Note & Velocity 
Show the MIDI note being played 
on an external MIDI control device 
and its velocity (from 0-27). 

12. Computer MIDI Keyboard Mode & MIDI Map Mode
 » Enable Computer MIDI Keyboard Mode 

to use your computer keyboard as a 

MIDI drum pad with the instruments laid 

out in a 4x4 grid and mapped according 

to the General MIDI Standard. Use the 

image to the right to identify what 

MIDI note number each key triggers.

 » Enable MIDI Map Mode to use an 

external controller with Liquid Rhythm. 

Any object with a red border can 

be assigned to a button, fader, or 

knob on a hardware controller.

13. Show/Hide Panel Buttons
Use these buttons to show and hide either the BeatBuilder or BeatWeaver 
panels. Alternatively, use the following key commands: 

 » BeatBuilder: [command]/[ctrl]+[1] 

 » BeatWeaver: [command]/[ctrl]+[2] 

 » Library: [command]/[ctrl]+[3] 

 » Molecule Tools: [command]/[ctrl]+[4] 

 » Mixer: [command]/[ctrl]+[5] 

http://en.wikipedia.org/wiki/General_MIDI#Percussive
http://en.wikipedia.org/wiki/General_MIDI#Percussive
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Chapter 7 Molecule Tools 

The Molecule Tools are a suite of MIDI effects along the bottom of the Liquid Rhythm window. 
They add variety, character, and excitement to the beats you create using Liquid Rhythm. From 

unexpected to completely musical, the results you get with these effects are totally up to you. 
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Accent Modifiers 
Use the Accent Modifiers to quickly 
and easily alter the velocity and/
or groove of a selected region(s). 

To access the Molecule 
Tools panel, either: 

 » Click the MT button to the 

far right of the toolbar. 

 » Press [command]/[ctrl]+[4] 

Strong, Medium, and Weak 
Each 8th note beat in a 4/4 bar has unique rhythmic significance. This 
musical nuance is visualized in Liquid Rhythm using dark, medium, and 
light tones of red and blue; these three tones are referred to as: 

Strong

Medium

Weak

Tip: Blue blocks represent note groupings of two and red blocks represent groupings of three. 

Accent Modifier Target Buttons 
Accent modifiers target the velocity and groove of a note(s) based 
on their positions within a beat or an entire bar. 

To toggle focus between the notes in a bar and the notes in a beat, click the 
Accent Modifiers Target buttons. 

 » BeatForm targets all the notes grouped 

by the smaller step sequencer. 

 » BarForm targets all the notes grouped 

by the larger step sequencer. 
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All the notes in 
the strong 
positions have 
lower velocities. 

Hovering over a slider highlights the affected 
notes. In this case, all the notes occurring 

on the weak beats are lit up.

Notice that 
changes are being 
applied at the 
BarForm level. 

Click the slider and drag 
up or down using your 
mouse to increase or 
decrease velocity. 

Humanize the velocity of your beat by dragging the handles 
above and below the sliders. Random velocity values 
within the slider’s range will be applied to the selection. 

Velocity Sliders 
Velocity Sliders target the velocity, or volume, 
as well as timbre of a sound(s) based on their 
position within the whole bar or single beat. 

Velocity Sliders in Action 
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Liquid Rhythm helps you keep 
track of what you’re editing: 
Hovering over a slider highlights 
the affected notes. In this case, 
all the notes occurring on the 
Strong beats are lit up. 

Click the slider and drag left 
or right to move the notes 
earlier or later in time. Humanize the groove of your beat 

by dragging the handles to the left 
and right of the sliders. Note that 
random groove values within the 
sliders’ range will be generated. 

Notice that the Notes in the 
Beat are being targeted. 

Groove Sliders 
Groove Sliders target the groove, or offset 
of time, of notes or groups of notes based 
on their position within a bar or beat. 

Groove Sliders in Action 
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Learn the velocity and 
groove values from the 
currently selected region(s) 
in the Arranger. 

Apply the velocity 
and groove values of 
the current sliders to 
all selected regions 
in the Arranger. 

When enabled, Auto adjusts 
velocity and groove settings 
to reflect the selected 
region(s) in the Arranger. 

Reset the velocity and 
groove values of the 
selected region(s) in the 
Arranger to defaults. 

Learn, Apply, Auto, Reset Buttons 
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BeatForm Palette 
BeatForms (or clusters of notes) can be used 
to create rhythmic variations instantly. The 
BeatForm Palette is a library of palettes 
that contain various note clusters. 

Interacting with individual BeatForms
The individual BeatForms in the BeatForm Palette are interactive objects. 

 » Drag-and-drop them onto tracks in the arranger to manually 

build rhythm patterns with note clusters.

 » Drag-and-drop them into the BeatWeaver panel to populate the In, Mid, Out Grid. 

 » Select the BeatForm you want to draw or paint with in BeatForm Edit mode. 



  

  Liquid Rhythm User Manual - Chapter 7

- 44 -

BeatForm Palette List 
Liquid Rhythm contains a list of factory sets of BeatForms including 
Suggested, Simple, Standard, Binary, Triplet Swing, and Glitch. 

Add and Remove BeatForm Sets 
Use the Plus button beneath the list the create a customizable User 
Set. If needed, click the Minus button to delete a user set. 

Zoom Into the BeatForm Palette 
The Magnifying Glass zooms into the Palette to give you a better look at the note clusters. 
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How the BeatForm Palette affects other features 
The following features and Molecule Tools in Liquid Rhythm are directly 
affected by the list you select in the BeatForm Palette: 

Randomizer 
 » Can be set to generate patterns using BeatForms contained in the Palettes. 

BeatForm Tumbler 
 » Each knob in the BeatForm Tumbler cycles through the BeatForms currently in the BeatForm Palette. 

BeatForm Sequencer 
 » BeatForms can be dragged into the Sequencer from the Palette. 

 » There is an option in the BeatForm Sequencer to automatically grab its contents from the Palette. 

 » To do so, right-click anywhere in the BeatForm Sequencer and 

select Auto-Load BeatForms from BeatForm Palette. 

BeatForm Editing 
 » When painting patterns with note clusters in BeatForm Editing mode, use the 

BeatForm Palette to select which note cluster you want to paint with. 

Tip: More information on how these features are affected can be 
found in this chapter in their respective sections. 
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Randomizer 
The Randomizer generates musically informed 
rhythm patterns from a customizable palette. 

To use it, either: 

 » Press the Surprise Me! button. 

 » Select Auto-Apply to apply changes 

as you drag the sliders. 

The generated results are based on four distinct parameters which can be activated or deactivated by 
clicking the checkbox to the left of each slider. Also, note that you can click and drag the yellow sliders. 

Random BarForm 
Activate BarForm to populate the selected region(s) in the Arranger with a BarForm(s) from the BarForm 
List. Click the arrow to the right of the slider to reveal a drop-down menu. It’s divided into two sections: 

Random BarForm Source 
a. The upper section of the drop-down menu is where you choose the 

list that the random BarForms will be chosen from. 

Slider Behavior 
b. The lower section of the drop-down 

menu defines the slider behavior: 

i. Slider indicates likelihood of change: 

The barform slider will indicate the 

likelihood that each of the selected bars 

will change when “Surpise Me!” is hit. 

ii. Slider indicates how different from 

previous: The Bar Form slider will 

indicate how different the generated 

beat can be from the current one. 

iii. Slider indicates target amount of activity: The barform slider will 

indicate how dense the generated beat should be. 
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Random BeatForm 
Activate Random BeatForm to populate the selected 
region(s) in the Arranger with a BeatForm(s) from the 
BeatForm Palette or BeatForm Sequencer. 

Click the arrow to the right of the slider to reveal a 
drop-down menu. It’s divided into two sections: 

Random BeatForm Source 
 » The upper section of the drop-down menu is where 

you can select the source of the random BeatForm. 

 » Note that selecting Follow Beat Sequencer 

means that these results will be directly linked 

to the contents of the BeatForm Palette. 

Repeat BeatForm on Accents 
 » The lower section of the drop-down menu features an option to Repeat BeatForm on Accents. Basically, 

this locks the same randomly generated BeatForm into each accent position (strong/medium/weak). 

For example, in the image below: 

8th notes BeatForms are repeated on the 
strong beats (or the four dark blue positions)

32nd note BeatForms are repeated on the 

weaker beats (or the four light blue positions). 
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Collaborate 
When Collaborate is active, it prevents notes from overlapping across each track - no two notes 
playing at the same time across the random generation. We call this “collaborate” because (in a 
sense) multiple drum instruments are collaborating on one distinct performance pattern. ``
Click the arrow to the right of the slider to reveal a drop-down menu. It’s divided into three sections: 

Collaboration Unit 
The top section of the drop-down menu is where you select the type of group to preserve when spreading 
notes across bars. For example, selecting BeatForm will 
cause notes grouped by BeatForms to stay together. 

Collaboration Shape 
The middle section of the drop-down menu is where you 
choose the shape to generate notes across. For example, to 
generate notes in a zigzag pattern, choose Sawtooth, select 
bars over three tracks in the arranger, and click Surprise Me! 

Cluster Count 
The last option in the drop-down menu is where 
you Select the number of units (BeatForm, BarForm, 
codon) to cluster together. (Higher numbers result in a higher number of sequential notes). 

The image below is an example of Collaborate in action. Note that the tracks have 
been folded to display the whole arrangement. The settings here are: 

 » Collaborate on Notes 

 » Sine 

 » Cluster Count: 3 
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Random Velocity and/or Groove 
The Random Velocity and/or Groove slider lets you control the amount of 
randomness in the new velocity, groove, or both velocity and groove values 
chosen. The higher the slider value, the more the velocity will vary. 

To select which parameter you want to control, click the arrow 
to show the drop-down menu and select either: 

 » Velocity 

 » Groove 

 » Velocity and Groove 

Tip: A great trick to humanize an entire beat very quickly is to select every 
region in the arranger, tune down the velocity, and click Surprise Me! 
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GrooveMover 
The GrooveMover rearranges the beats in your 
bar, giving you instant variations or remixes of your 
note patterns. To use it, click the up and down 
arrow buttons, or the colored pattern buttons. 

Understanding the GrooveMover
Every 4/4 bar used in Liquid Rhythm is categorized by four unique rhythmic accent patterns (the uppermost 
row of colors in the image above). The dark colors represent accented 8th notes in a 4/4 bar; the light 
colors represent the less-stressed beats. These patterns come into play with all our editing tools, so you 
don’t just get random results when experiementing; the results will be based on beats you have made.

When you apply the GrooveMover, note clusters that originally occur on dark-colored 
spaces move to the new dark-colored locations. This way, though your accents have 
clearly changed, the resulting beat still shares some commonality with the original. 

Tip: Try selecting every region in a four bar loop and applying GrooveMover. 

Move Notes 
Deselect Move Notes to override Liquid Rhythm’s underlying pattern 
suggestions without shifting the notes around. 

Simply click on a BarForm pattern (any colored rectangle) to swap it into the selected region(s). 

Tip: Notice how the Accent Modifiers shift as you change underlying BarForm patterns. Try different 
patterns to use the Accent Modifiers on and to get a wider variety of results from the GrooveMover. 
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BeatForm Tumbler 
With the BeatForm Tumbler, you can select a region(s) in the Arranger and 
tumble through possible rhythmic variations, affecting either: 

 » Each of the eight beats in the bar individually. 

 » Strong, Medium, and Weak positions in a bar. 

Click either Position or Beat to switch between the two. To use 

the tumblers, simple click and drag the knobs. 

How the BeatForm Palette affects the BeatForm Tumbler 
Use the BeatForm Palette to determine which BeatForms you can cycle through 
while using the Tumblers. For example, select the Simple palette to limit your 
options to “simple” BeatForms in the Tumblers (as illustrated below): 
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Chapter 8 The Library 

Liquid Rhythm features a resource library with a wide variety of acoustic and electronic 
drum, percussion, and pitched percussion samples. Specify which version(s) of the library 
you want to download in the popup window located at Help > Download Additional 
Instruments. If, for any reason, your internet connectivity is lost during the library download, 
Liquid Rhythm will automatically resume the download on application restart. 

Instruments 
The Instruments tab consists of acoustic, 
electronic, percussive, and pitched Instruments 
comprised of 1-10 samples, each responding to 
various velocity ranges—this allows for realistic 
dynamics and expression when performing or 
programming a beat. For a dramatic and instant 
demo of how this sounds, use the Accent Modifiers 

Scroll up or down to navigate through the 
entire list or use the filter buttons below 
the tabs to narrow your selection options 
to a specific instrument grouping. 

Alternatively, search for Instruments by 
typing the desired name into the search field 
directly below the instrument type buttons. 
To load an instrument, simply double-click it. 

Kits 
The Kits panel consists of matching Instruments 
that can be loaded simultaneously, like a DnB kit 
or a Rock kit. Every kit included in Liquid Rhythm 
is premapped to General MIDI, so your hardware 
controllers will automatically work with our kits.

To load a kit, double-click it. 

Tip: Use the kits panel to get 
started quickly and easily. 
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Loops 
The Loops panel consists of kits and drum 
loops stored in Liquid Rhythm’s library. 

Click the buttons below the Library tabs 
to narrow your selection options by genre. 
For example, click the R n B button to 
limit your selections to R n B beats. 

Alternative, use the search field below the genre buttons to type in a genre. 
To load a loop, double-click it. 

Samples 
We encourage you to also use your own 
samples when making beats with our software. 
That’s why Liquid Rhythm features a Samples 
tab in its library. After all: DJs, producers, and 
electronic musicians tend to work pretty hard 
to curate an exclusive selection of sounds. 

Compatible file types include: .mid, 
.midi, .wav, .wave, .aif, .aiff. 

All you need to do to access your samples is: 

1. Click the Samples tab in the Library. 

2. Click the Add Folder button at 

the bottom of the pane. 

3. Navigate to the folder containing your 

sample library and click Open. 

As with the instruments included in 
Liquid Rhythm, you’ll be able to audition 
and load any compatible sample in your 
personal collection. Simply double-click 
a sample and a new track will be created containing it. 
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Audition Tools 
All the Instruments in Liquid Rhythm’s 
library can be auditioned before loading 
them. To do so, click any Instrument.
 
To control the audition volume for an 
instrument, kit, or loop, click the audition 
volume fader and drag your mouse left or 
right to decrease or increase the volume. 

Stop Audition Playback 

To stop the playback of a instrument, kit, or loop, click the stop button, 
indicated by the small square on the bottom right of the library panel. 

Auto-Audition Mode 

Auto-audition makes it possible for you to hear the instruments, kits, and loops 
in Liquid Rhythm’s library as you click on them. It is enabled by default.
 
To toggle it on or off, click on the Auto-Audition Mode button indicated by a speaker. 

Loop Audition Kit Selection Menu 

Liquid Rhythm’s Loops library has been 
designed to pair genres with appropriate 
sounding kits. You can, however, select 
a kit you prefer to audition various 
genres of loops with. To do so: 

1. Deselect the Use Default Kit 

button by clicking on it. 

2. Select the kit you prefer from the 

Loop Audition Kit Selection Menu. 
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Kit Editor 
Use the Kit Editor to create and save 
your own personalized kits within 
Liquid Rhythm using the multi-sample 
instruments included with the software 
or samples in your personal library. 

Tip: Kits can only be created in Standalone 
mode. When used with Ableton Live, your 
kits will be built using the Drum Rack 
and saved in Ableton Live’s Browser. 

Create a Kit
To create 
a kit in standalone mode, follow these steps: 

1. Open Liquid Rhythm and click the Lib button to open the library.

2. In the Library panel, click on the Kits tab to view your kit library.

3. Click the Kit Editor button at the bottom of the panel to open the Kit Editor window. 

4. In the Kit Editor window, click the Add Instrument… button to explore all the factory and user 

instruments and samples in your library. Click any instrument or sample to add it to your new kit. 

5. To save your drum kit, click File > Save Kit As... You can now close the editor and use your kit! 

6. To edit a kit, right-click it and select Edit Kit from the drop-down menu. 
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Instrument Editor 
With Liquid Rhythm’s Instrument Editor, you can 
create your own multi-sample instruments with 
customized articulations and velocity ranges. Liquid 
Rhythm recognizes both wav and aiff audio files. 

Loading a Sample 
There are three ways to load a sample: 

 » click the Load Sample Button and select 

an audio file located on your hard drive. 

 » click File > Load Sample Into Instrument or 

use the [command]/[ctrl]+[L] key command 

to launch the Open dialog box. 

 » drag-and-drop a WAV or AIF file into the Sample Velocity Manager window. 

Loading Multiple Samples Simultaneously 

Adding multiple samples simultaneously when 
creating a instrument is easy. To do so, select 
up to 127 wav or aiff files and drag them into 
the Sample Velocity Manager window. 
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Velocity Map 
The Velocity Map maps MIDI input velocity (x-axis) 
to playback velocity (y-axis) for each sample. 

Sample ranges are distinguished from one 
another using purple and gray shading. 

The Velocity Map is an interactive environment. 
To draw a velocity curve manually: 

1. Click the left mouse button and drag your mouse. 

2. Press and hold [shift] while dragging 

to draw a straight line. 

3. Notice that yellow crosshairs follow the 

mouse pointer to highlight your location 

on the graph and Map Articulation Point 

indicators beneath the Instrument Audition 

display your coordinates for reference, helpful in fine-tuning Articulation Regions. 

Reset the Velocity Map 

To reset the Instrument Map, right-click anywhere on the map 
to open the drop-down menu and click Reset Velocity Map. 
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Auditioning Samples 
To audition a sample, click the Audition Sample 
button to the left of the Articulation Region. 
This plays the sample as it is, ignoring any 
velocity changes you may have applied. 

Instrument Audition Bar 

To audition multiple samples with the Velocity 
Curve applied, use the Instrument Audition Bar. 

Click anywhere in it to hear the sample within the 
Articulation Region playback at the assigned velocity. 

Adjusting Articulation Boundaries 
MIDI input velocities are assigned to samples using the Adjust Articulation Boundaries 
bar. Click and drag the black dividers to manually set the boundaries. 

If you have defined uneven Articulation Boundaries and you want to add a new sample without 
disrupting the present configuration, deselect Auto-Resize located in Options > Auto-Resize. 

Tip: When you add multiple samples, or with each subsequent sample you add to your 
instrument, the Articulation Boundaries are automatically resized uniformly. 

In the example below, the first sample will be triggered by 

velocity input MIDI values ranging from 0 – 17. 
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Assigning a MIDI Note to an Instrument 
There are a variety of ways to assign a MIDI note to a instrument: 

 » click a key on the Piano Roll to assign it to the instrument. In the example below, A2 

triggers the instrument. click a pad in the Drum Pad to assign it to the instrument. 

 » with an external MIDI controller connected to your computer, press the MIDI Learn button 

and then press a key or drum pad on your controller to assign it to the instrument. 

Tip: Note that all the drum instruments in Liquid Rhythm follow the General 
MIDI Standard. For your reference, the Instrument field displays the percussion 
instrument type typically associated with the selected note. 

Saving an Instrument 
 » To save a new instrument, click File > Save Instrument As 

 » To save an existing instrument you have edited, click File > Save Instrument 
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Chapter 9 The Mixer 

Every instrument you load from the library has a corresponding track header in the 
arranger canvas and a channel strip in the mixer. Launch the mixer panel by either pressing 
the Mix button on the top right of the screen or by pressing [command]/[ctrl]+[5]. 

Channel Strip 
The following is a detailed description of the 
features found on a channel strip: 

1. Track Title 
 » This field displays the name of the instrument 

associated with the channel strip. 

 » By default, it inherits the name of the instrument 

loaded into the track. Click in the dialog box 

to enter a custom title for the track. 

2. MIDI From 
 » Set which external or internal MIDI device 

you want to use to trigger the instrument 

associated with this channel strip by clicking 
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the drop down arrow and selecting the device of your choice. 

 » To change which MIDI channel the internal or external device communicates through and 

which MIDI note value triggers the instrument loaded in the channel strip, click on the 

Chan and/or Note value(s) and drag your mouse up or down to redefine the values. 

3. MIDI To 
 » You can use Liquid Rhythm as a sequencer and send MIDI data to external or internal devices. 

To do so, click the drop down arrow and select the device of your choice, and set the Chan 

and Note values to match the corresponding values on your external or internal MIDI device. 

Tip: Setting your MIDI To values when you’re unsure about your computer’s MIDI setup can create an 
abrasive feedback loop that might startle you, and, worse, might damage your speakers. Please take 
great care when sending MIDI from the tracks in Liquid Rhythm to tracks in other pro audio software! 

4. Audio To 
 » Use the Audio To drop-down list to define the output routing for a track. 

 » As a VST or AU in multi-output mode, this feature allows you to send the Kick, Snare, 

and Hi-Hats, for example, to their own exclusive channels in your host DAW. 

Tip: This feature enables you to really fine-tune the sound of your beat in plug-in mode. 

5. Instrument Swap 
 » Click the Instrument Swap button to swap any sound in the Library for the one you have 

presently loaded. The track name updates to reflect the new instrument loaded. 

 » With Instrument Swap activated, open the Sample Browser to swap 

WAV and AIF files from your personal Library into a track. 

6. Instrument Selector 
 » The Instrument Selector drop down menu contains every instrument 

in Liquid Rhythm’s resource library. Click the menu and select any 

instrument to replace the one currently loaded into your track. 
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7. Volume Fader, Balance Knob, Solo, Mute, & Record 
 » The volume fader, balance knob, solo, mute, and record buttons are autonomous 

with those found on the instrument’s corresponding track header. For 

information about them, please see Track Headers in Chapter 3. 

Tip: Any changes made to the volume, balance, solo, mute and record 
of a channel strip will instantly reflect in the track header. 
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Master Channel Strip 

1. I/O (Input/Output) 
 » Click the I/O button to reveal the audio and MIDI input 

and output routing options for the tracks in the Mixer. 

2. Master Balance Knob 
 » Varies the relative level of the left and right channels 

in the Master channel. Click on the knob and drag 

the mouse up and down to change its value. 

 » [command]+click the knob to return it to its default value. 

3. Master Volume 
 » Adjusts the volume for the Master channel. Note that this affects the volume of the entire mixer. 

4. Master Mute
 » Mutes the Master channel. 

5. Metronome Volume
 » Adjusts the playback volume of the metronome track.
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Chapter 10 The BeatBuilder 

The BeatBuilder is a rhythm pattern generator and 8-step sequencer with a twist. Use it to make 
beats the way you would use Legos to build a spaceship; that is, using the right parts for the job. 

The BeatBuilder panel (on the right of the Liquid Rhythm window) is 
open by default, but to access it at any time press either: 

 » [Tab] 

 » [command]/[ctrl]+[1] 

 » Click the BB button on the right of the toolbar. 

How to Use the BeatBuilder 
 » The BeatBuilder works on one or more bars 

simultaneously, but at least one must be selected. 

 » Select a bar in the Arranger canvas to activate 

it. If the arranger is empty, create a track or load 

a instrument from the library to get started. 

 » Notice how as you click on different patterns 

in the BeatBuilder, the selected region(s) in the 

Arranger become populated with that pattern. 

 » The BeatBuilder consists of two panels: 

BarForm List 

BeatForm Sequencer 
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BarForm List 
The BarForm List contains one-bar long rhythm patterns. 

 » Click a pattern to insert or swap it into the selected region(s) in the Arranger

 » Drag-and-drop a pattern on a region in the Arranger. 

BarForm Filters 
Use the BarForm Filter buttons on the 
bottom of the BarForm List to populate 
the list with a variety of results. 

Suggested 
 » The top twenty most occurring 

patterns for the instrument you have 

selected, appear on the list. 

 » These patterns are identified 

by the BeatSeeker. 

Similar 
 » Patterns most rhythmically similar to the 

one you have selected in the Arranger. 

Favorites 
 » Right-click on a pattern in the list 

to add it to your Favorites list. 

 » Scroll through all your preferred 

rhythm patterns using this list. 

All 
 » View every possible combination of 8th notes 

and rest in a 4/4 bar; 256 total patterns. 



  

  Liquid Rhythm User Manual - Chapter 10

- 66 -

BeatBuilder Quick Insert 
To quickly swap and insert any of the top ten patterns in the 
BarForm List results, perform the following steps: 

1. In the menu bar, go to Insert > BeatBuild Quick Insert. 

2. Select from Quick Barform Select 1 through 10. 

For your joy, the top ten results in your BarForm List are mapped to keyboard 
shortcuts. The Quick Barform Select keyboard commands are: 

 » [control]/[ctrl]+[press any number 1 – 0 where 1 is the first 

entry and 0 is the tenth entry in the BarForm List] 

Tip: Note that on Windows, [ctrl]+[0] will not correspond to the tenth entry in the BarForm List. 
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BeatForm Sequencer 

Sequencer 
The BeatForm Sequencer contains a list of 
potential variations on each eighth-note beat in 
the pattern selected in the above BarForm List. 
It can affect one or more selected bars in the 
Arranger simultaneously. Use it to access 

complex rhythmic variations very quickly. 

Add BeatForms to the Sequencer
 » Click the Add… button and select a palette to load a set of 

BeatForms. Note that greyed columns are inactive. 
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Working with the BeatForm Sequencer
You’ll notice that the BarForms you select from 
the BarForm List contain purple BeatForms 
(that is, the 8th note BeatForm) by default. 

Use the BeatForm Sequencer to access 
other note clusters (or BeatForms) that fit 
into the space of one purple 8th note. 

 » Click any of the blue or red BeatForms 

to substitute them for the purple 

BeatForm in the same column. 
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The BeatForm Sequencer will reflect the 
BarForm pattern you have selected by 
highlighting all the active spaces. 

 » To activate an inactive space, click 

it. To deactivate it, click it again. 

 » To apply a BeatForm across an 

entire BarForm, click any of the 

corresponding arrows to the left. 

 » To delete a row, click any of the 

corresponding Xs on the right. 
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Surprise Me!
 » Click Surprise Me! for a random 

pattern based on the BeatForms 

loaded across the active columns. 

 » Click Clear to remove any 

unused BeatForms. 

Remixer 
Click the Remixer button to view a 

comprehensive list of rhythmic possibilities.

This list is built based on: 

 » The BarForm pattern you have 

selected in the BarForm List.

 » The BeatForm Set you have 

loaded from the Add… list. 
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Chapter 11 The BeatWeaver Rhythm 
Synthesizer 

The BeatWeaver Rhythm Synthesizer can make any bar a work of 
rhythmic art, quickly. To open the BeatWeaver panel: 

 » Click the BW button on the right of the toolbar. 

 » Key command: [command]/[ctrl]+[2] 

How to Use the BeatWeaver 
The BeatWeaver works on one or more bars simultaneously, but at least one must be selected. 

 » Select a bar in the arranger canvas to activate it. 

 » If the arranger is empty, create a track or load a instrument from the library to get started. 
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The BarForm & BeatForm Maps 
Throughout this manual, two new terms that have been used frequently are BarForm and BeatForm. 
To recap, a BarForm is a one-bar pattern of music and a BeatForm is 
cluster of notes that fits into the space of an eighth-note.

BarForm Map 
 » The BarForm Map is a palette of one-

bar rhythm patterns that can instantly 

be inserted into your arrangements. 

 » With eighth note subdivisions, there are 256 

total combinations of notes and rests. 

 » Click any pattern to immediately load it into 

the selected bar in the arranger. Hold [option]/

[alt] and click any BarForm to audition it. 

Zooming Into the BarForm Map 
 » Click the Magnifying Glass tool to the 

right of the BarForm map to get a better look at the BarForm in the wheel. 

 » Use the Rotate Map buttons above and below the Magnifying 

Glass to spin the wheel clockwise or counterclockwise. 

Tip: Click around various bars in the Arranger. Notice how the BeatWeaver reflects 
the selection(s) in the arranger? Every element in the BeatWeaver is closely 
related to whatever region you have selected in the arranger canvas. 
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BeatForm Map 
 » The BeatForm Map contains note groups 

that are equal to or higher resolution 

than 8th notes, such as 8th’s, 16th’s, 

16th note triplets, as well as rests. 

 » [option]/[alt]+click to audition 

any BeatForm. 
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Deployment Bins 
When you click on a BeatForm in the wheel 
above, it is deployed (or placed) into the selected 
Deployment Bins, indicated by a black border. 
Press and hold [shift] to place 
multiple BeatForms into a bin. 
In the example shown, the two 
BeatForms selected in the map have 
been deployed to the Strong bin. 
Tip: From left to right, the bins target Strong, 
Medium, and Weak beats. If the BarForm you’ve 
selected in the arranger is comprised of groupings 
of two (blue), the Medium bin will be disabled. 

Deployment Bins In Action 
 » In the example to the right, 

the purple rectangles indicate 

that only 8th notes appear 

on the strong, medium, and 

weak positions of the beats 

within that BarForm. 

 » Note that the illustrated indicators beneath the Deployment Bins 

show which beats the selected BeatForms, are applied to. 

 » For your reference, the indicators display the BarForm to the right of the deployment bins, 

which mirrors the BarForm you 

have selected in the arranger. 

 » Notice that the BarForm Step Sequencer 

in the BeatWeaver panel is identical to 

the BarForm selected in the arranger. 

 » Changes made in this step 

sequencer are reflected in the 

arranger. To manually input a note, 

click above the colored pattern. 
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BeatForm Sequence List 
Note that when you select BeatForms from the 
BeatForm Map, the BeatForm Sequence List gets 
populated with every possible measure that results 
from the unique ordering of your selections. 
Placing three BeatForms in every Deployment Bin 
results in a tremendous BeatForm Sequence List. 
We encourage you to experiment with this feature 
and to enjoy the speed with which you can create 
intricate and unique kick, snare, and hi hat patterns! 

BeatForm Sequence List Tools 
1. To remove unused BeatForms from the bins, 

click the Discard Unused BeatForms button. 

2. Sometimes in software, as in life, you might 

get lost. You were driven by passion and 

curiosity but perhaps ventured too far from 

home. Well, we encourage the expeditionary, 

in fact, we facilitate it. Spiral out; keep going. 

To find the currently selected BeatForm 

pattern in the Sequence List, click the 

Find Current BeatForm Pattern button. 

3. To gain a better visual perspective 

of where new BeatForms are 

introduced in the Sequence 

List, click the Fade Identical BeatForms check box. 
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Chapter 12 MIDI Mapping

You can control many of Liquid Rhythm’s parameters with a hardware controller. Play drums on 
a physical drum pad, sequence clusters of notes using buttons, or assign any of our molecule 
tools’ controls to a fader or knob. We’ve made the mapping process easy and intuitive!

With the full version of Liquid Rhythm, you get custom mappings for Ableton Push, MIDI 
Designer, and the iConPad. Liquid Rhythm Intro includes the iConPad exclusively. 

MIDI Mapping Mode

Assigning Parameters
To activate MIDI Mapping Mode, either:

 » Select Options > MIDI Mapping Mode > Edit MIDI Map

 » Use the [Command}/[ctrl]+[M] key command. 

Once activated, all assignable parameters will be highlighted in red.
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To assign a parameter to a control:

1. Select the parameter by clicking it with your mouse.

2. Move/press the button/fader/knob you want to assign it to. 

Mappings List
Assigned parameters appear in the Mappings list. Keep track of your custom 
mapping using this list, and delete any mappings you don’t need anymore. 

Note that all parameters that appear in this list will be highlighted in 
blue, while the selected list item will have a teal border. 
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MIDI Scripts
The wizards of WaveDNA have devoted some time to crafting custom MIDI 
maps for some of our favorite devices. In the following pages, we’ll describe the 
setup process, as well as the workflow for those hardware controllers. 

iConPad Template

Overview  
We’ve mapped some of the most useful features in Liquid Rhythm to the iConPad. The result is 
a fun and simple way to get started making beats extremely quickly. In the following pages, we’ll 
describe the setup process and button layout to help you drastically simplify your workflow.
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Setup
With the iConPad connected to your computer, follow these instructions:

1. Run Liquid Rhythm.

2. Go to Liquid Rhythm > Preferences or use the [Command]/[ctrl]+[,] key 

command to access the Settings menu and select the Devices tab.

3. Find iCON iCon PAD and select Factory Midi Mapping Preset for all the available options.
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Device Controls

Navigation
Turn these two dials to navigate through the arranger horizontally and vertically. 
Pressing the buttons will cycle up and down through choices in the barform list.

Beat Building and Sequencing
 » Buttons 1 through 10 are mapped to the first 10 BarForms in the BeatBuilder. 
 » Pal Up and Pal Down are mapped to the BarForm tumble up/down’ buttons. 
 » The arrows control the Cycle BeatForm tool. 

 » The Up and Down buttons cycle between the first 10 and next 10 choices of the BarForm list.
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Accent Modifiers 
The first three vertical faders are mapped to the strong, medium, and weak velocity locations 
in the Accent Modifiers (dark blue / red, medium red, and light blue / red shades).

The next set of faders are mapped to the strong, medium, and weak groove 
locations (dark blue / red, medium red, and light blue / red shades).
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The Shaper buttons cycle through upward, downward, or random slopes that 
affect the distribution of velocity information. The dials affects the range of how 
the shaper is applied to the groove information across the various shades.

Mute
Press the Mute button to mute Dark, Medium or Weak shaded notes. This is a great way to thin 
out a pattern or alter its feel in an interesting and rhythmic way. Turn the Mute buttons to control 
the range of how the shapers are applied to the velocity information across the various shades.
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Ableton Push Integration 
Ableton’s Push has a user mode that is designed for programmers to access in 
order to build customized scripts and interfaces to run alongside the regular 
workflow of Push. Liquid Rhythm’s Liquid Rhythm Script mode allows for expanded 
access to the features of Liquid Rhythm within the Live environment. 

Getting started - Setup 
In order to use the Liquid Clips Push Integration, you will need to make small adjustments 
in three places: Ableton Live, 
Liquid Rhythm, and Push: 

Setting up Ableton 
1. Make sure that the proprietary Python 

script for Ableton Push has been loaded. 

Go to Ableton’s Preferences > MIDI Sync 

and select Push for one of the Control 

Surface slots. Live will make all the rest 

of the connections automatically. 

2. In the MIDI Ports section, enable Track 

and Remote inputs for Ableton Push. 
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3. From the Max for Live category in the Live 

Library, select the LiquidRhythm.amxd device 

and drag-and-drop it onto a MIDI track in Live. 

Setting up Liquid Rhythm 
1. Go to Liquid Rhythm’s Preferences by either: 

a. Clicking LiquidRhythm > Preferences. 

b. Press [command]/[ctrl]+[,] 

2. Click the Devices tab. 

3. Select Liquid Rhythm Script for Push. 

Setup Push 
 » On the Push, press the USER button to enter and exit Liquid Rhythm Script 

and enjoy nNavigating the Push with Liquid Rhythm Script enabled 
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Event Feedback Display 
On the top left corner of the display, track information is displayed and updated as you play around: 

 » Tracks that are empty will appear with _ 

 » Tracks with notes present will display X 

 » Tracks that are muted will show M 

 » Tracks that are soloed will show S 

64 Pads 
The 64 pads of Push awesomeness are 
excessively fun to play with. Here are some 
points to consider while doing so: 

 » The grid of 64 pads buttons is designed 

to display the BeatForms present 

in the BeatForm Sequencer. 

 » Each of the 8 horizontal rows of buttons in 

the grid represent time broken into 8 steps. 

 » Each of the 8 vertical rows are broken 

into 8 clusters of notes (BeatForms) 

that fit into each step. 

 » The display of the BeatForm sequencer is 

static by default, showing only the information 

present in the BarForm that is selected. 

 » By pressing the TAP TEMPO button you can 

‘animate’ the selection to follow the playhead, 

so the view will cycle as the bars chase by. 
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Resolution Buttons/Scene Buttons 
 » These [1⁄4] [1⁄4t] [etc..] buttons running vertically to the right of 

the 64 pads correspond to entries in the BarForm list. 

 » Use these buttons to insert any of the first eight BarForms in the 

BarForm List into the selected region(s) in the Arranger. 

 » Hold [shift] and press these buttons to access the next set of BarForms in the BarForm List. 
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Pages and Modes 
In Liquid Rhythm Script Mode, Push has seven pages for editing and interfacing 
with numerous parameters found within the Molecule Tools panel. 
Push’s Display will show information relevant to the mode in focus. The 
narrower rectangular buttons above the 64 Pads and below the Display 
correspond directly to the bottom two rows of text on Push’s Display. 
Note that the bottom 64 Pads remain a dedicated interface for editing the BeatForm Sequencer. 

Arrange 

Arrange contains basic arranger functions across the bottom row of white buttons. 
Press-and-hold the SHIFT button and turn any of the 8 knobs above the display 
to rearrange these functions to suit your needs. The functions are: 

 » Cut 

 » Copy 

 » Paste 

 » Tog Drag (Toggle Drag) 

 » Tog Sel (Toggle Selection) 

 » Sel Row (Select Row) – Press-and-hold SHIFT to Latch Select Row on 

 » Sel Col (Select Column) - Press and hold SHIFT to Latch Select Column on 
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View 

The View page has zoom and loop related tools: 

 » Zoom Fit 

 » Zoom Def (Zoom Default) 

 » Zoom + 

 » Zoom - 

 » Loop Tog (Loop Toggle) 

 » Loop Sel (Loop Selection) 
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Accent Modifiers 

The Accent Modifiers page has three sections: 

 » Velocity 

 » Offset 

 » Shaper 

The first three knobs above the display are set to control the Strong, Medium, and Weak 
sliders. The fourth knob controls all three at the same time. This functionality is mirrored 
for all three sub modes (Velocity / Offset / Shapers). Common buttons in each page are: 

 » Reset 

 » BarForm/BeatForm 

 » Mt Strong (Mute Strong Shaded Notes) - Hold SHIFT to delete strong shaded muted notes. 

 » Mt Med (Mute Medium Shaded Notes) - Hold SHIFT to delete medium shaded muted notes. 

 » Mt Weak (Mt Weak Shaded Notes) - Hold SHIFT to delete weak shaded muted notes. 
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GrooveMover 

 » Up - Cycles the BarForm family up 

 » Down - Cycles the BarForm family down 

 » 1 - picks first BarForm family 

 » 2 - picks second BarForm family 

 » 3 - picks third BarForm family 

 » 4 - picks fourth BarForm family 

Randomizer 

The first four knobs above the display control the amount of variance in 
the BarForm, BeatForm, Collaborate, and Velocity/Groove parameters. 
Press the buttons beneath each category to enable them: 

 » BarForm 

 » BeatForm 

 » Collaborate 

 » Velocity 

 » Suprise Me! 
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BeatForm Tumbler 

When you enable the BeatForm Tumbler page, the eight knobs above the display (excluding the 
9th, somewhat-sequestered knob) correspond to the eight locations in a selected region(s) in 
Liquid Rhythm. There are two modes in this page: Position and Beat. The available commands are: 

 » Palette+ 

 » Palette- 

 » Sequencer 
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General buttons
In addition the multiple pages and modes shown in 
the display, a number of buttons from Push’s natural 
workflow have functions in Liquid Rhythm Script:

Undo 
 » Undoes

SHIFT+Undo 
 » Redoes

Delete 
 » Deletes the selection

Double 
 » This duplicates the selected region(s) 

Duplicate 
 » Creates new clip

New 
 » Creates a new scene and an empty clip slot to record in

In/Out 
 » Zoom in / Zoom out 

 » Press and hold to zoom quickly. 

 » Hold SHIFT to zoom all the way in or out. 

Mute 
 » Mutes the selected track in Liquid Rhythm / Drum rack in live 

Solo 
 » Solo’s the selected track in Liquid Rhythm / Drum rack in live 

Select 
 » Toggles selection drag on/off 

SHIFT 
 » Acts as a modifier for some of the buttons and 

encoders in the various Push pages 

TAP TEMPO 
 » Region focus follows playhead. 



  

  Liquid Rhythm User Manual - Chapter 12

- 93 -

Push General Command pages 
The volume, pan/send, track, clip, device, and browse buttons allow the user 
to exit our script to return to normal functionality. Alternatively pressing and 
holding these buttons allow the user to ‘peek’ at those functions and return to our 
script. The same behaviour is present for the Note and Session modes. 
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Midi Designer Template 
Liquid Rhythm  Version 1.4.2 +  

Overview 
This MIDI Designer template gives the user of Liquid Rhythm or Liquid Clips 
a comprehensive yet  approachable set of commands and controls that 
help speed up the interaction between humans  and the software.  
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Installation and Setup   

Installation  
1. Load the Midi Designer file to your iPad using iTunes.  Using 

the apps tab locate the MIDI designer app.  

2. Press the Add... button. 
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3. Locate the file “Liquid Rhythm.mididesigner” from the folder you downloaded. 

4. Press Add. 
Now the script is on your ipad!  
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Wifi connection on Mac 
1. On your ipad, join the same network your computer is on. Either 

your home network, or create  your own ad hoc network.   

2. Creating your own network is easy.  Simply click on the wifi logo 

on the top right toolbar and select ‘create network’.  

3. Type a custom name for it.  

4. It might also be a good idea to make this network secure with a password.   

5. Join the network you just created on your ipad and you’re ready!  
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The next step is to connect your iPad to your computer. 

1. Go to the ‘Applications’ folder and click ‘Utilities’.  

2. Launch ‘Audio MIDI Setup.’ 

3. Click on window and choose ‘Show MIDI Window’ to view the MIDI setup page.  

4. Press the ‘Network’ icon. 
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5. Press the + button to create a new session.  

6. Locate your iPad on the list below and connect to it.  

If you’re having trouble, or it’s your first time ever using MIDI Designer, look at http://mididesigner. 
com/help/connect/. It has a great section on getting started.                                           

http://mididesigner.


  

  Liquid Rhythm User Manual - Chapter 12

- 100 -

Setting up Ableton 
Once you are connected with MIDI Designer, you need to make a few connections in Ableton Live:   

1. In Live, go to Live > Preferences... and select the MIDI tab.    

2. Locate the Network (Session 1) row and make sure Track and Remote are on.  
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3. Launch Liquid Rhythm, or load the Max for Live Liquid Clips patch, in Ableton Live.

4. If you are running Liquid Rhythm as a plugin or Max for Live patch, navigate 
to Options > MIDI  Mapping Mode > Import Recent Mapping... and load ‘Liquid 
Rhythm Midi Designer Template. mm’. If you are running Liquid Rhythm in 
Standalone, load ‘Liquid Rhythm Midi Designer  Template Standalone.mm’.  

5. In Ableton, on the track that has the Liquid Clips max patch,  turn the monitor input switch 
on.   This is needed to allow MIDI information to be passed through to Liquid Clips,  and it 
allows for  MIDI information stored as automation information in Clips to be routed through.                         
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Views and Modes  

Main page 
This is the default page.  The left top area remains focused at all times on the BeatForm 
Sequencer.   The lower portion of the left page toggles between navigation/editing tools 
and the BeatForm  Tumbler. The bottom zones are various pages related to the Molecule 
Tools and their controls.  The  interface can be switched using the tabs at the top:  
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The right half of the interface holds pages that control various sections of the Molecule Tools.  Mod,  
ModC, Blist and Rand contain many relevant controls you would require:  

 » Mod - this page holds the accent modifiers and beat tumbler controls 

 » ModC - is the accent modifiers and editing controls 

 » Blist  - holds the beatform list and Groovemover 
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Navigation and Editing  

This section contains many common editing tools: 

 » Copy:  Copies selected BarForms to clipboard Paste:  Pastes selected BarForms 

from clipboard Delete: Deletes selections Duplicate:  Duplicates selections 

 » Drag: allows the user to move a selected BarForms around in the 

arranger of Liquid Rhythm emulates  a click and drag. 

 » Up, left, down, right: For navigating the selection choices  

 » Zoom to selected region: Zooms on the selected region 

 » Zoom to Default: Zooms out back to normal view 

 » Undo: Undo the last action 

 » Redo: Redo the last action 

Update  (for Liquid Clips Ableton patch) allows the user to update information without having to flip  
between programs in order to refresh the Liquid Rhythm interface.  
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BeatForm Sequencer  

This is a mapped representation of the BeatForm Sequencer. 

 » On the left side the white squares correspond to the ‘Set All BeatForms’ 

arrow button, which sets all  columns to the BeatForm in that row.        

 » The central cluster of boxes are the grid of BeatForm locations. The colours alternate 

between white  and blue to give the user a sense of timing and location.  
                                        
Note: At the present moment there is no visual feedback showing the 
state of the BeatForm  Sequencer.  (You have to imagine it!)  
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Accent Modifiers  

 » The vertical faders are mapped to the strong, medium, or weak velocity 

(dark blue / red, medium  red, and light blue / red shades):  
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 » The horizontal faders at the bottom are similarly mapped to the strong, medium, and 

weak groove  positions (dark blue / red, medium red, and light blue / red shades):  

 » The ‘Shaper’ buttons select upward, downward, or random slopes 

that affect the distribution of  velocity information:  

 » The ‘Mute’ button allows the user to mute Dark, Medium or Weak shaded notes.   

 » The ‘Del mutes’ button will delete any notes that are muted:  
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 » The Bar/Beat button toggles the way the accents are affected by the sliders.   In Bar mode the  

faders apply the changes based on the placement of the colours as they are distributed across 

the  BarForms.  In Beat mode the shades of the individual BeatForms are modified instead.  
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BeatForm Tumbler pages  

The first half of this page is mapped to the BeatForm Tumbler. Strong, Medium, 
and Weak knobs are  mapped to their counterparts in the beat mode. 

The All knob affects all of the shades at once.  
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 » The purple arrows represent the controls of the Cycle Panel.  They allow the 

user to shift the  selected patterns’ notes one 8th step to the left or right.  

 » ‘Pal Up’ and ‘Pal Down’ buttons cycle through the choices of 

palettes the BeatForm sequencer will  use.  

 » In ‘Position Mode,’ the 8 faders are mapped to the 8 dials in the tumbler.   The 

shading and position  of these dials is in sync with the BeatForm Sequencer’s 

steps. The leftmost fader,  ‘All’ fader, affects  all steps in the sequencer.  
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BarForm List  

Buttons 1 through 10 are mapped to the first 10 BarForms in the BeatBuilder. ‘Pal 
Up’ and ‘Pal  Down’ are mapped to the BarForm tumble up/down’ buttons.  The 
arrows are attached to the Cycle  BeatForm tool.  The ‘Up’ and ‘Down’ buttons 
cycle between the first 10 and next 10 choices of the  BarForm list.  
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GrooveMover  

This interface allows for the shifting of the color accent patterns that are present in each BarForm.   

 » The four shapes redistribute the color shades of the accents in a barform.   

 » The arrow up and down buttons cycle through the choices.   

 » Auto returns the underlying pattern to its default.   

 » Activate toggles how the device functions either by shifting 

the colors and notes together or just  the colors.  
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Randomizer  

 » The yellow faders are mapped to the four faders in the Randomizer 

that deal with how the  Randomizer applies its choices.  

 » The ‘Surprise Me’ button will surprise you!  It will randomize the selected region.   

 » Each of the buttons to the left of the sliders governs whether or not the sliders’ 

variables will be  represented when the ‘Surprise Me’ button is pressed.   

 » The ‘Auto’ button automatically applies the changes the sliders make as you move them.  
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Chapter 13 Help and Troubleshooting 

On-Screen Help 

There is a panel at the bottom of the Liquid Rhythm window that displays 
descriptions about application elements. To use, hover the cursor over 
buttons, menus, panels, and other on-screen elements. 

Troubleshooting 
When using Liquid Rhythm, as with any software, problems can arise. The following 
section addresses some of the more common problems our users have come across. 

I can’t hear any music or sound: 

OSX: 
1. Go to the OSX system preferences in  > System Preferences and ensure 

that the output source is set to the device you want to use. 

2. Ensure the volume on your speakers is turned up/turned on. 

3. Ensure that the audio driver in Liquid Rhythm’s settings is set to the device you 

want to use. To access the audio settings, navigate to Options > Settings. 
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I followed the Liquid Clips Installation guide properly but still 
can’t get it to work 

Have you ever adjusted the location of your Max For Live library in 
Live? If so, when you run the Liquid Rhythm installer, the LiquidRhythm.
amxd file will be placed in the default folder you no longer use. 

To ensure the success of Liquid Rhythm’s Max for Live patch: 

1. Locate the LiquidRhythm.amxd file. OSX: /Users/[your name]/Music/

Ableton/User Library/Presets/MIDI Effects/Max MIDI Effect 

2. Make sure you place the LiquidRhythm.amxd file in your custom Max For Live folder. 

3. Restart Live and try again. 
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Anatomy of a Molecule



  

  Liquid Rhythm User Manual - Glossary

- ii -

Examples of BeatForm Notation
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